Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Report lässt sich nicht erstellen

Report lässt sich nicht erstellen 1 Monat 1 Tag her #1735

  • AndreasK.
  • AndreasK.s Avatar
  • Offline
  • Fresh Boarder
  • Beiträge: 18
  • Dank erhalten: 1
  • Karma: 0
Guten Abend zusammen!
Wir haben seit dem 01.03. OpenZ aktiviert.
Jedoch tritt jetzt folgendes Problem auf:
Wenn ich eine Bestellung erstelle, aktiviere und dann den Report drucken möchte kommt folgender fehler: (aber nicht bei jeder Bestellung)
org.openbravo.erpCommon.utility.reporting.ReportingException:

Aktualisiere ich die gleiche Bestellung und bleibe im "Bearbeitungs" Modus und möchte dann den Report erstellen kommt folgender fehler:
Report processing failed
Unable to process report selection

Wähle ich bei der gleichen Bestellung "Nein, nur drucken" aus kommt folgender fehler:
Es wird eine PDF erstellt die ich auch speichern kann welche jedoch 0 Byte groß ist.
Welche ich logischer weise nicht öffnen kann.

Ich arbeite noch mit der 3.6.0.0.79 Version.

Noch folgende Informationen zu der Bestellung:
Die Bestellung besteht mehrfach aus dem gleichen Artikel
Sie unterscheiden sich nur aus dem Text in der Beschreibung und der Stückzahl.

Wenn ich der Bestellung den gleichen Artikel ohne Beschreibung hinzufüge funktioniert wieder alles.
Oder ich ändere die Positions-Nummern von 10, 20, 30 ... in 1, 2, 3 ... dann funktioniert es auch wieder.
Total kuriose...

Hat jemand eine Idee woran es liegen könnte?

Gruß
Andreas
Letzte Änderung: 1 Monat 1 Tag her von AndreasK..
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Report lässt sich nicht erstellen 4 Wochen 1 Tag her #1736

  • thomas
  • thomass Avatar
  • Offline
  • Moderator
  • Beiträge: 200
  • Dank erhalten: 55
  • Karma: 8
Hallo Andreas.

Hier reicht die Bandbreite von verstellten Einstellungen der Dokumente, über falsch eingestellte Templates bis zur 'Nutzung von (versteckten) HTML-Befehlen in der Positionsbeschreibung.

Solche Fragestellungen zu individuellen 'Fehlergebnissen' sind im Forum nur schwer zu beantworten.
Dafür ist ein Blick ins System notwendig um die Gemengelage der Daten zu analysieren.

Gruß Thomas
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Report lässt sich nicht erstellen 2 Wochen 6 Tage her #1737

  • AndreasK.
  • AndreasK.s Avatar
  • Offline
  • Fresh Boarder
  • Beiträge: 18
  • Dank erhalten: 1
  • Karma: 0
Guten Tag,

nach längerer Fehleranalyse bin ich zu folgender Lösung gekommen:

Bei mir lag es daran, das der Artikel, bei gelagert kein Haken gesetzt war.
Jedoch war bei Lagerort ein Lagerplatz eingetragen.
Sobald ich bei Lagerort keine Auswahl treffe, sprich das Feld bleibt leer.
Funktioniert alles einwandfrei.

Gruß
Andreas
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Report lässt sich nicht erstellen 2 Wochen 5 Tage her #1738

  • thomas
  • thomass Avatar
  • Offline
  • Moderator
  • Beiträge: 200
  • Dank erhalten: 55
  • Karma: 8
Hallo Andreas.

Schön das Du für dich eine Lösung gefunden hast.

Ich habe versucht den Fehler in meinem aktuellen Testsystem (Version 3.6.60) nachzustellen, was leider ( oder zum Glück) nicht funktionierte.
Das Anlegen mehrerer Positionen mit gleichem Artikel (5x) und unterschiedlichen Positionsbeschreibungen und Mengen führte nicht in einem einzigem Fall zu der von dir oben aufgeführten Fehlermeldung bei Nutzung des OpenZ-Standardreportes.
Ich vermute daher, das es hier einen weiteren Parameter geben muss der zu dem Fehler führt.

Kannst Du Ausschließen das zeitgleich andere Einstellungen verändert wurden?
Wir finden ein Zusammenhang an dieser Stelle sehr verwunderlich und können zunächst keinen Zusammenhang erkennen.

Gruß Thomas
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Ladezeit der Seite: 0.024 Sekunden