Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1
  • 2
  • 3

THEMA:

Installationsproblem - ant wad.lib 6 Jahre 10 Monate her #113

  • PB
  • PBs Avatar Autor
  • Besucher
  • Besucher
Hallo OpenZ-Team,

leider habe ich ein Instalationsproblem. :-(

Mein System ist:
Ubuntu 12.04
Tomcat 7.0.42
Java 1.7.0_25-b30
PostgreSQL 9.1
Openz 2.6.74

Die Installation war bis zum Punkt "Das System "zusammenbauen"" problemlos, erst wenn ich - ant wad.lib - eingebe erhalte ich folgende Fehlermeldung

BUILD FAILED /home/openz/build.xml:247: The following error occurred while executing this lin /home/openz/src-wad/build.xml:67: srcdir "/home/openz/src-wad/build/javasqlc/src

Meine Fehlersuche hat ergeben, dass der "src" nicht vorhanden ist.
Aus diesen Grund habe ich das Arhiv nochmal entpackt und src-Ordner und alle Unterordner und Dateien im o.g. Verzeichnis abgespeichert. Wenn ich jedoch - ant wad.lib - ausführe wird der Ordner wieder gelöscht.

Mache ich etwas falsch?

MfG. Peter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von danny.

Re: Installationsproblem - ant wad.lib 6 Jahre 10 Monate her #114

  • stefan
  • stefans Avatar
  • Besucher
  • Besucher
Das verschwinden des src-Ordners ist bei keinem unserer Entwicklungssysteme bislang vorgekommen.

Es handelt sich um eine Einstellung auf Ihrer Maschine, welche können wir allerdings von hier aus nicht feststellen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 10 Monate her #115

  • Heso
  • Hesos Avatar
  • Besucher
  • Besucher
Hatte genau das gleiche Problem unter Windows 8. Habe den Rechner bestimmt 3 mal neu aufgesetzt und konfiguriert und hatte immer den selben Fehler. Unter Windows 7 funktionierte es allerdings sofort.

Wenn man sich unter Windows 8 die Konsole anschaut, wenn man den Befehl "ant wad.lib" ausführt, kann man erkennen, dass zu Beginn mehrere Ordner gelöscht werden, nicht alle aber wiederhergestellt werden.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 10 Monate her #116

  • PB
  • PBs Avatar Autor
  • Besucher
  • Besucher
Hallo.

Wie ich bereits oben aufgelistet habe, benutze ich

Ubuntu 12.04

Das ist keine vertuelle Maschine, sonder reines Linux-System.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 10 Monate her #118

  • danny
  • dannys Avatar
  • Besucher
  • Besucher
Hallo Herr Buss,

ich persönlich nutze ebenfalls ein Ubuntu 12.04, vielleicht kann ich Ihnen bei Ihrem Problem ein wenig unter die Arme greifen.

Mein System sieht dabei im Grunde so aus:
Ubuntu 12.04
java-7-openjdk-amd64 als Java
Tomcat 7.0.42
Postgresql 9.1
Ant

Könnten Sie evtl einmal die Deployment logs posten, damit ich die kompletten Zeilen einmal sehen kann die dazu führen, dass ant abbricht?

Ich vermute bei Ihrem Problem, das es nicht das Problem mit dem src Verzeichnis ist, sondern ein Konfigurationsfehler in den config Dateien (Openbravo.Properties) oder sogar in der build.xml. Ich kann mich erinnern, einen ähnlichen Fehler bei der Einrichtung gehabt zu haben.
In diesen Dateien ist es außerordentlich wichtig, dass die Pfad angaben übereinstimmen. Wichtig sind in diesem Zusammenhang aber auch die Umgebungsvariablen. Wenn Sie die Ergebnisse, davon noch einmal hinzuposten könnten, bin ich mir sicher eine Lösung für Sie zu finden.

Mit freundlichen Grüßen
Danny Heuduk

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 9 Monate her #120

  • PB
  • PBs Avatar Autor
  • Besucher
  • Besucher
Hallo danny und alle andere,

habe mich entschieden komplettes System neu zu installieren.
Meine Schritte

1. Installation von Ubuntu 12.04 - 64 Bit auf einem root-Server.

2. Dann nach Installationanleitung
- PostgreSQL Version 9.1
apt-get install postgresql-9.1
apt-get install postgresql-contrib-9.1

- Java7 SDK
apt-get install openjdk-7-jdk

- Tomcat 7
apt-get install tomcat7
apt-get install ant

3. OpenZ heruntergeladen und ins /home/openz entpacken

mkdir /home/openz
cd /home/openz/
wget freefr.dl.sourceforge.net/project/openz/.../openz_2.6.74.tar.gz
tar xvfz openz_2.6.74.tar.gz
cd

4. Eintrag im /etc/environment.

vim /etc/environment.

CATALINA_HOME="/etc/tomcat7/"
CATALINA_BASE="/etc/tomcat7/"
JAVA_HOME="/usr/lib/jvm/java-7-openjdk"
ANT_HOME="/usr/share/ant"
CATALINA_OPTS="-Xms384M -Xmx512M -XX:MaxPermSize=256M"

5. Die Datenbank

su - postgres
psql
create role tad;
alter role tad with password 'password';
alter role tad login;
alter role tad SUPERUSER;
create database openz;
\q

6. Openbravo.properties im config-Verzeichnis Modifizieren

vim /home/openz/config/Openbravo.properties


# ************************************************************************

# Documentation at wiki.openbravo.com/wiki/Openbravo.properties

####################
# Date/time format #
####################

dateFormat.js=%d-%m-%Y
dateFormat.sql=DD-MM-YYYY
dateFormat.java=dd-MM-yyyy
dateTimeFormat.java=dd-MM-yyyy HH:mm:ss
dateTimeFormat.sql=DD-MM-YYYY HH24:MI:SS

###########
# General #
###########

# Static content URL. Use the default value to make it dynamic.
# Don't change this unless you know what you are doing
web.url=@actual_url_context@/web

# Context name, used in the final war file
context.name=openz

# Absolute path to the attachments directory
attach.path=/home/openz/attachments

# Absolute path to the external Multimedia Data Directory
multimedia.path=/tmp

#########################
# DEPLOYMENT Parameters #
#########################

# Absolute path to the tomcat directory
tomcat.path=xxx

# Absolute path to the deploy log directory
deploylogging.path=xxx

# Absolute path to the distribution directory
distribution.path=xxx

# Absolute path to the tarball directory
tarball.path=xxx


#Deploy mode: valid values [class, war, none]
deploy.mode=class

############
# Database #
############


bbdd.rdbms=POSTGRE
bbdd.driver=org.postgresql.Driver
bbdd.url=jdbc:postgresql://localhost:5432
bbdd.sid=openz
bbdd.systemUser=postgres
bbdd.systemPassword=syspass
bbdd.user=tad
bbdd.password=tad
bbdd.sessionConfig=select update_dateFormat('DD-MM-YYYY')

##################
# Tomcat manager #
##################
#
tomcat.manager.url=http://localhost:8080/manager
tomcat.manager.username=admin
tomcat.manager.password=tad

##########################
# Development parameters #
##########################

bbdd.outputscript=databasescript.sql
bbdd.verbosity=INFO

# CSS Sprites Generator
generateSprites=no

# use js/css minimization (in local-context and war-file)
minimizeJSandCSS=yes

# How sqlc should execute the queries embedded in xsql file at compilation time
# traditional: only uses the base query ignoring all optional parameters
# optimized: includes most optional parameter to achieve better performance
# If optimized fails for some xsql files, downgrade level to traditional
sqlc.queryExecutionStrategy=optimized

##################
# Authentication #
##################

# Leave this empty to use the default login hardler.
# LAM server example: org.openbravo.authentication.lam.LamAuthenticationManager
authentication.class=

###########
# Add-ons #
###########

# External Pentaho Services
pentahoServer=

##############
# Validation #
##############

validate.model=true
isMinorVersion=false



7. Dump in die Datenbank importieren

psql openz < /home/openz/openz.sql

8. Zusammenbauen
ant core.lib
Ausgabe: Build failed



Was mache ich falsch?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 9 Monate her #121

  • danny
  • dannys Avatar
  • Besucher
  • Besucher
Hallo zuerst einmal möchte ich mich für den ausführlichen Beitrag bedanken. Dass hilft mir sicherlich etwas genauer zu antworten.

So was mir als erstes auffällt ist die Ungleichheit der Passwörter in den Openbravo.properties und der Datenbank an sich.
(Frage für mich sind die Befehle für die Datenbank aus unserer Anleitung? Wenn ja, müssen wir die zügig ändern)
In den Properties steht:
bbdd.user=tad
bbdd.password=tad

Und im Postgres setzen Sie das Passwort 'password' mit
alter role tad with password 'password';

Dies könnte schon einmal ein Grund für Fehler sein.

Darüber hinaus würde ich mich freuen, wenn Sie mir kurz zeigen könnten wie die Echos der environment-Variablen aussehen, oft beinhalten diese nämlich falsche Werte...
Dies machen Sie uA mit dem Befehl:
Befehl--> echo $CATALINA_HOME
Ergebnis--> /home/user/tomcat7

Für weitere Fragen stehen wir Ihnen gerne weiterhin zur Verfügung!
Mit freundlichen Grüßen
Danny Heuduk

PS: Seit letzter Woche ist unter Downloads/Links und Downloads die aktuellste Version von OpenZ verfügbar (2.6.76), sowie unter Downloads/Changelogs das dazugehörige Changelog verfügbar.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Re: Installationsproblem - ant wad.lib 6 Jahre 8 Monate her #163

  • PB
  • PBs Avatar Autor
  • Besucher
  • Besucher
Hallo danny,

ist es möglich Sie persönlich zu Kontaktiren?
Habe immer noch Probleme mit Installation.

Danke

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2
  • 3
Ladezeit der Seite: 0.160 Sekunden