Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: OpenZ aus Asustor NAS

OpenZ aus Asustor NAS 5 Jahre 5 Monate her #311

  • Heso
  • Hesos Avatar
Hallo, ich bins mal wieder mit einer Frage. Soch zuerst einmal die Hintergrundgeschichte:

Ich besitze Privat ein NAS von Asustor. Das AS608T, um genau zu sein:
www.asustor.com/product?p_id=2&lan=en

In der Firma setzen wir seit 01.04.2014 produktiv das aktuelle OpenZ in Ihrer vorkonfigurierten virtuellen Maschine ein. Diese läuft auf meinem Arbeitsrechner. Das bedeutet, ist mein Rechner aus, so kann auch niemand in OpenZ rein.

Nun möchten wir uns in der Firma eben jenes NAS anschaffen und OpenZ darüber laufen lassen. Da das NAS eine App für Postgres und eine App für Tomcat hat, sollte dies auch mit ein paar Tricks möglich sein.

Nur bekomme ich das nicht so richtig hin. Ihre Anleitungen für Windows und Linux lassen sich logischerweise nicht 1:1 bei dem NAS anwenden.

Die Datenbank habe ich bereits am laufen, nur schaffe ich es nicht, OpenZ über Tomcat zu starten. Es passiert einfach nichts. Was kann ich da noch ausprobieren?

Asustor bietet ein Demosystem für das NAS an, falls Sie sich ein Bild davon machen möchten: www.asustor.com/live_demo?lan=en
Letzte Änderung: 4 Jahre 7 Monate her von Heso.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: OpenZ aus Asustor NAS 5 Jahre 5 Monate her #312

  • danny
  • dannys Avatar
Hallo Heso,

da wir das noch nicht getestet bzw. versucht haben ist es recht schwierig eine Aussage zu treffen ob und wie das funktionieren kann.
Deshalb ein paar fragen meinerseits.
Lassen sich die Sourcen von OpenZ kompilieren? (ant core.lib etc.)
Was sagt das Tomcat-Log? (catalina.out bzw openz.log)

Vielleicht lässt sich so erkennen, was noch gemacht werden müsste.

Beste Grüße

Danny
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: OpenZ aus Asustor NAS 5 Jahre 5 Monate her #313

  • Heso
  • Hesos Avatar
Was das kompilieren angeht, erkläre ich am besten mal meinen Installationsversuch von Anfang bis Ende. Da auf dem NAS nämlich kein Winant läuft und ich es nicht auf dem NAS kompilieren kann (was vermutlich auch der Grund dafür ist, dass es nicht läuft), musste ich hier einen anderen Weg gehen:

Auf meinem Windows-Rechner habe ich folgendes gemacht:
- Openz in C:\ entpackt (Pfad: C:\openz)
- Postgres installiert (nur für PGAdmin)

Auf dem NAS habe ich folgendes gemacht:
- Postgres installier
- Tomcat7 installiert

Installation von Openz:
1. Per PGAdmin die Datenbank vom NAS eingebunden
2. Openz Datenbank (wie eurer Anleitung) aufgebaut (keine Fehler)
3. Umgebungsvariablen gesetzt (Tomcat variablen auf Pfad von NAS eingestellt)
4. System kompiliert (ebenfalls ohne Fehler)

Das Ergebnis sieht so aus, dass die über build.deploy übergebenen Daten im NAS im Tomcat Ordner an der richtigen Stelle sind und auch die Datenbank ist funktionstüchtig. Starte ich nun aber Tomcat und versuche OpenZ (oder auch die Tomcat Standard Seite) aufzurufen, so kommt nur: Die Seite kann nicht angezeigt werden

Das Tomcat-Log werde ich nachreichen, bin auf der Arbeit und habe hier kein Zugriff darauf.

Aber vielleicht lässt sich ja hier schon was mit anfangen.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: OpenZ aus Asustor NAS 5 Jahre 5 Monate her #314

  • Heso
  • Hesos Avatar
Habe gestern versucht, an die logs zu kommen. Leider ohne Erfolg. Werde mich da die nächsten Tage noch mal dransetzen und ein paar Sachen durchprobieren.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: OpenZ aus Asustor NAS 5 Jahre 5 Monate her #320

  • danny
  • dannys Avatar
Hallo Heso,

vielen Dank erst einmal für diese Informationen.

Es sieht mir derzeit danach aus, dass der Tomcat keinerlei Ressourcen für die Anwendung hat und dadurch nicht starten kann. Wie die Portbelegungen des NAS aussehen kann ich leider auch nicht sagen, es könnte sein, dass die Tomcat Std Ports evtl anderweitig belegt sind (8080/8009).
Eine andere Fehlerquelle könnte auch die Übertragung der Daten sein, ist es möglich einen Dump von Ihrem Windows PC dort aufs NAS zu kopieren und diesen per Konsole zu importieren? Denn so ist es nur möglich Fehler durch unnötige Steuerzeichen auszuschließen.

Vielleicht hilft mein Ansatz.
Freue mich über eine Rückmeldung.

Danny
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: OpenZ aus Asustor NAS 4 Jahre 7 Monate her #612

  • Heso
  • Hesos Avatar
Nach einer doch recht langen Wartezeit melde ich mich hier zu dem Thema mal zurück, da es bei mir jetzt wieder aktuell ist.

Seit gestern versuche ich die neue Version von Openz (3.08) auf dem NAS zum laufen zu bringen, jedoch erfolglos.

Ausgangssituation:
1. Windows 8.1 Rechner
- Postgres 9.2 installiert
- Java JDK 7 installiert
- Winant 7 installiert
- Tomcat 7 installiert

2. NAS
- Java JRE installiert (Leider ist kein JDK verfügbar)
- Postgres 9.2 installiert
- Tomcat 7 installiert
(Kein Ant auf dem NAS verfügbar)

Folgendes habe ich versucht:
1. OpenZ Datenbank installieren
- tad + openz auf NAS nach eurer Anleitung angelegt
- psql.exe -h "IP-vom-NAS" -p 5432 -d openz -U postgres < C:\openz\openz.sql
Fazit: Datenbank installieren ohne Fehler erfolgreich

2. Umgebungsvariablen (unter Windows)
Benutzerdefinierte Variablen:
- ANT_HOME = C:\Program Files (x86)\WinAnt (Pfad ist korrekt)
- JAVA_HOME = C:\Program Files (x86)\Java\jdk1.7.0_65 (Pfad ist korrekt)
Systemvariablen:
- CATALINA_HOME = S:\
- CATALINA_BASE = S:\
- CATALINE_OPTS = -Xms384M -Xmx512M -XX:MaxPermSize=256M
Der Pfad S:\ steht für den Netzwerkfreigabeordner der webapps von Tomcat.

3. OpenZ kompilieren
(Folgende Befehle unter Windows ausgeführt)
- ant core.lib -> successful
- ant wad.lib -> successful
- ant trl.lib -> successful
- ant compile.complete -> successful
- ant build.deploy -> successful

Nach diesem Vorgehen habe ich im Freigabeordner von Tomcat den folgende Struktur:
S:\webapps\openz
Der Ordner webapps ist hierbei überflüssig, da der Freigabeordner bereits die webapps beinhaltet. Leider kann ich das aber nicht umstellen.
Daher verschiebe ich openz in den root von S:\, also zu S:\openz

Sobald ich das erledigt habe, schmiert Tomcat auf dem NAS ab und kann erst nach einer kompletten Neuinstallation von Tomcat und dem Löschen des Freigabeordners wieder gestartet werden.

Ich habe auch schon versucht, die Umgebungsvariablen auf dem NAS mittels SSH einzutragen. Leider hat es auch nicht geholfen.

Wäre für ein paar Tipps sehr dankbar.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Ladezeit der Seite: 0.021 Sekunden